summaryrefslogtreecommitdiff
path: root/gnu/packages/selinux.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-13 13:42:39 +0200
committerMarius Bakke <marius@gnu.org>2022-08-13 19:24:35 +0200
commit54f14833a93eab22d0c4f95e3fc38106e150f3d0 (patch)
tree24124bd7ade841dbf611067ef2c2ac646f73e53f /gnu/packages/selinux.scm
parent86084aa4c8ecbedbb946bca97df17de2c1995970 (diff)
downloadguix-patches-54f14833a93eab22d0c4f95e3fc38106e150f3d0.tar
guix-patches-54f14833a93eab22d0c4f95e3fc38106e150f3d0.tar.gz
gnu: libselinux: Remove input labels.
* gnu/packages/selinux.scm (libselinux)[arguments]: Use G-expression. [native-inputs, inputs, propagated-inputs]: Remove labels.
Diffstat (limited to 'gnu/packages/selinux.scm')
-rw-r--r--gnu/packages/selinux.scm59
1 files changed, 29 insertions, 30 deletions
diff --git a/gnu/packages/selinux.scm b/gnu/packages/selinux.scm
index 18422ffe2e..93c256371a 100644
--- a/gnu/packages/selinux.scm
+++ b/gnu/packages/selinux.scm
@@ -136,43 +136,42 @@ module into a binary representation.")
(arguments
(substitute-keyword-arguments (package-arguments libsepol)
((#:make-flags flags)
- `(cons* "PYTHON=python3"
- (string-append "LIBSEPOLA="
- (assoc-ref %build-inputs "libsepol")
- "/lib/libsepol.a")
- (string-append "PYTHONLIBDIR="
- (assoc-ref %outputs "python")
- "/lib/python"
- ,(version-major+minor (package-version python))
- "/site-packages/")
- ,flags))
+ #~(cons* "PYTHON=python3"
+ (string-append "LIBSEPOLA="
+ (search-input-file %build-inputs
+ "/lib/libsepol.a"))
+ (string-append "PYTHONLIBDIR="
+ #$output:python
+ "/lib/python"
+ #$(version-major+minor (package-version python))
+ "/site-packages/")
+ #$flags))
((#:phases phases)
- `(modify-phases ,phases
- (delete 'portability)
- (replace 'enter-dir
- (lambda _ (chdir ,name)))
- (add-after 'build 'pywrap
- (lambda* (#:key make-flags #:allow-other-keys)
- (apply invoke "make" "pywrap" make-flags)))
- (add-after 'install 'install-pywrap
- (lambda* (#:key make-flags outputs #:allow-other-keys)
- ;; The build system uses "python setup.py install" to install
- ;; Python bindings. Instruct it to use the correct output.
- (substitute* "src/Makefile"
- (("--prefix=\\$\\(PREFIX\\)")
- (string-append "--prefix=" (assoc-ref outputs "python"))))
- (apply invoke "make" "install-pywrap" make-flags)))))))
+ #~(modify-phases #$phases
+ (delete 'portability)
+ (replace 'enter-dir
+ (lambda _ (chdir #$name)))
+ (add-after 'build 'pywrap
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke "make" "pywrap" make-flags)))
+ (add-after 'install 'install-pywrap
+ (lambda* (#:key make-flags #:allow-other-keys)
+ ;; The build system uses "python setup.py install" to install
+ ;; Python bindings. Instruct it to use the correct output.
+ (substitute* "src/Makefile"
+ (("--prefix=\\$\\(PREFIX\\)")
+ (string-append "--prefix=" #$output:python)))
+
+ (apply invoke "make" "install-pywrap" make-flags)))))))
;; These libraries are in "Requires.private" in libselinux.pc.
(propagated-inputs
- `(("libsepol" ,libsepol)
- ("pcre2" ,pcre2)))
+ (list libsepol pcre2))
;; For pywrap phase
(inputs
- `(("python" ,python-wrapper)))
+ (list python-wrapper))
;; These inputs are only needed for the pywrap phase.
(native-inputs
- `(("swig" ,swig)
- ("pkg-config" ,pkg-config)))
+ (list pkg-config swig))
(synopsis "SELinux core libraries and utilities")
(description
"The libselinux library provides an API for SELinux applications to get