summaryrefslogtreecommitdiff
path: root/gnu/packages/search.scm
diff options
context:
space:
mode:
authorAlexandr Vityazev <avityazev@posteo.org>2021-10-04 21:52:32 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-10-08 12:07:35 +0200
commit55092b49803477b9ae0cd89ab01ce3275cf75d0e (patch)
tree798d88f12261a89d229f21e940b4c6fe7401d39b /gnu/packages/search.scm
parentd3862d12bb1b69b395015caa480c1461ac6a575d (diff)
downloadguix-patches-55092b49803477b9ae0cd89ab01ce3275cf75d0e.tar
guix-patches-55092b49803477b9ae0cd89ab01ce3275cf75d0e.tar.gz
gnu: Add plocate.
* gnu/packages/search.scm (plocate): New variable. Add the required imports from (guix build-system meson) and (gnu packages pkg-config). Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/search.scm')
-rw-r--r--gnu/packages/search.scm34
1 files changed, 33 insertions, 1 deletions
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index 44d5b631ca..bc2a556848 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2018 Adam Massmann <massmannak@gmail.com>
;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021 Alexandr Vityazev <avityazev@posteo.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -33,6 +34,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
+ #:use-module (guix build-system meson)
#:use-module (gnu packages)
#:use-module (gnu packages compression)
#:use-module (gnu packages check)
@@ -51,7 +53,8 @@
#:use-module (gnu packages time)
#:use-module (gnu packages web)
#:use-module (gnu packages xdisorg)
- #:use-module (gnu packages xml))
+ #:use-module (gnu packages xml)
+ #:use-module (gnu packages pkg-config))
(define-public xapian
(package
@@ -333,6 +336,35 @@ with slocate, and attempts to be compatible to GNU locate when it does not
conflict with slocate compatibility.")
(license gpl2)))
+(define-public plocate
+ (package
+ (name "plocate")
+ (version "1.1.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://plocate.sesse.net/download/"
+ "plocate-" version ".tar.gz"))
+ (sha256
+ (base32 "0kwfp3hwf9dbakf3h378qrhl0jd1spxxrs4snmgb5jsbdijwd777"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:configure-flags
+ (list
+ (string-append
+ "--sharedstatedir=" (assoc-ref %outputs "out") "/var"))))
+ (inputs
+ `(("liburing" ,liburing)
+ ("zstd" ,zstd "lib")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://plocate.sesse.net/")
+ (synopsis "Faster locate")
+ (description "Plocate is a @code{locate} based on posting lists,
+completely replacing @command{mlocate} with a faster and smaller index. It is
+suitable as a default locate on your system.")
+ (license gpl2)))
+
(define-public swish-e
(package
(name "swish-e")