summaryrefslogtreecommitdiff
path: root/gnu/packages/sdl.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-05-27 23:19:49 +0200
committerLudovic Courtès <ludo@gnu.org>2014-05-27 23:19:49 +0200
commitaf018f5e0a1b7c67e9f40ca68929bd35b94206d3 (patch)
tree8c3efe66f8ac1f6178357937c0a41c6f5ff8f0f8 /gnu/packages/sdl.scm
parentd84a7be6675bd647931d8eff9134d00dd5a6bd58 (diff)
parent35066aa596931ef84922298c2760ceba69940cd1 (diff)
downloadguix-patches-af018f5e0a1b7c67e9f40ca68929bd35b94206d3.tar
guix-patches-af018f5e0a1b7c67e9f40ca68929bd35b94206d3.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/sdl.scm')
-rw-r--r--gnu/packages/sdl.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index d86ecde38e..bbf8597c7a 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -147,12 +147,17 @@ other supporting functions for SDL.")
(base32
"16an9slbb8ci7d89wakkmyfvp7c0cval8xw4hkg0842nhhlp540b"))))
(build-system gnu-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config)))
;; FIXME: Add webp
- (inputs `(("libpng" ,libpng)
- ("libjpeg" ,libjpeg)
- ("libtiff" ,libtiff)
- ("pkg-config" ,pkg-config)))
- (propagated-inputs `(("sdl" ,sdl)))
+ ;;
+ ;; libjpeg, libpng, and libtiff are propagated inputs because the
+ ;; SDL_image headers include the headers of these libraries. SDL is a
+ ;; propagated input because the pkg-config file refers to SDL's pkg-config
+ ;; file.
+ (propagated-inputs `(("sdl" ,sdl)
+ ("libjpeg" ,libjpeg)
+ ("libpng" ,libpng)
+ ("libtiff" ,libtiff)))
(synopsis "SDL image loading library")
(description "SDL_image is an image file loading library for SDL that
supports the following formats: BMP, GIF, JPEG, LBM, PCX, PNG, PNM, TGA, TIFF,