summaryrefslogtreecommitdiff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-11-02 23:44:50 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-11-03 03:10:52 +0100
commit34d76cbc1dfe99ba8b2228734fe6e3987c4dc45f (patch)
tree95625b7fa97a3a0e252a4753027781759ad4b1de /gnu/packages/samba.scm
parentedc9832fcc9c089451c05ee6bccd2fb81d275207 (diff)
downloadguix-patches-34d76cbc1dfe99ba8b2228734fe6e3987c4dc45f.tar
guix-patches-34d76cbc1dfe99ba8b2228734fe6e3987c4dc45f.tar.gz
gnu: ldb: Update to 2.4.1.
* gnu/packages/samba.scm (ldb): Update to 2.4.1. [source]: Don't explicitly return #t from snippet.
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index db2a75d1d3..fad2888f03 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -396,14 +396,14 @@ many event types, including timers, signals, and the classic file descriptor eve
(define-public ldb
(package
(name "ldb")
- (version "2.4.0")
+ (version "2.4.1")
(source (origin
(method url-fetch)
(uri (string-append "https://www.samba.org/ftp/ldb/ldb-"
version ".tar.gz"))
(sha256
(base32
- "10rd1z2llqz8xdx6m7yyxb9a118gx2xxwri18bhkkab9n1w55rvn"))
+ "13yd7lavbx8bxwnmzl0j7xnl2gl4wmnn0q9g7n3y7bvbnhm07hb9"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -412,8 +412,7 @@ many event types, including timers, signals, and the classic file descriptor eve
(unless (or (string-prefix? "third_party/waf" file)
(string-suffix? "wscript" file))
(delete-file file)))
- (find-files "third_party"))
- #t))))
+ (find-files "third_party"))))))
(build-system gnu-build-system)
(arguments
'(;; LMDB is only supported on 64-bit systems, yet the test suite