summaryrefslogtreecommitdiff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-25 08:28:31 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:32 +0200
commitd31b86a698350738f0763e9850ed33dc6cfeefce (patch)
tree1ec358bb40de69489139c062cae9c30b2fc43c26 /gnu/packages/rust.scm
parenta65361cff124d12712065884cf7d548a1e13d180 (diff)
downloadguix-patches-d31b86a698350738f0763e9850ed33dc6cfeefce.tar
guix-patches-d31b86a698350738f0763e9850ed33dc6cfeefce.tar.gz
gnu: rust: Update supported-systems.
* gnu/packages/rust.scm (rust-1.55)[supported-systems]: Explicitly list systems where the final rust compiler builds successfully. Change-Id: Icb89dd4eec1404a9d8db54029e69dae02a66f19e
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 959b08b8d0..f792aa0061 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -541,7 +541,8 @@ ar = \"" binutils "/bin/ar" "\"
;; rustc invokes gcc, so we need to set its search paths accordingly.
(native-search-paths
%gcc-search-paths)
- (supported-systems (delete "i586-gnu" %supported-systems))
+ ;; Limit this to systems where the final rust compiler builds successfully.
+ (supported-systems '("x86_64-linux" "aarch64-linux" "riscv64-linux"))
(synopsis "Compiler for the Rust programming language")
(description "Rust is a systems programming language that provides memory
safety and thread safety guarantees.")