summaryrefslogtreecommitdiff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-06-26 12:27:50 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-06-26 12:35:26 +0300
commit41891ea973b9cd658a6cc42875f8c65953eb6e12 (patch)
tree4c9cc19ce25af4e203cbc15f166bc06a183edc97 /gnu/packages/rust.scm
parent0fd8c0031eba02f390f524ba5ba11511d8db9212 (diff)
downloadguix-patches-41891ea973b9cd658a6cc42875f8c65953eb6e12.tar
guix-patches-41891ea973b9cd658a6cc42875f8c65953eb6e12.tar.gz
gnu: Add rust-1.79.
* gnu/packages/rust.scm (rust-1.79): New variable. Change-Id: Idf54e6504eca7e8cf8a49e664e5aa6c8ff18555d
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index d490069a24..a385344473 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -985,6 +985,32 @@ safety and thread safety guarantees.")
(rust-bootstrapped-package
rust-1.77 "1.78.0" "1afmj5g3bz7439w4i8zjhd68zvh0gqg7ymr8h5rz49ybllilhm7z"))
+(define-public rust-1.79
+ (let ((base-rust (rust-bootstrapped-package rust-1.78 "1.79.0"
+ "1h282jb1yxc69999w4nhvqb08rw2jy32i9njdjqrz78zglycybhp")))
+ (package
+ (inherit base-rust)
+ (source
+ (origin
+ (inherit (package-source base-rust))
+ (snippet
+ '(begin
+ (for-each delete-file-recursively
+ '("src/llvm-project"
+ "vendor/jemalloc-sys-0.5.4+5.3.0-patched/jemalloc"
+ "vendor/openssl-src-111.28.1+1.1.1w/openssl"
+ "vendor/tikv-jemalloc-sys-0.5.4+5.3.0-patched/jemalloc"))
+ ;; Remove vendored dynamically linked libraries.
+ ;; find . -not -type d -executable -exec file {} \+ | grep ELF
+ ;; Also remove the bundled (mostly Windows) libraries.
+ (for-each delete-file
+ (find-files "vendor" "\\.(a|dll|exe|lib)$"))
+ ;; Adjust vendored dependency to explicitly use rustix with libc backend.
+ (substitute* '("vendor/tempfile-3.7.1/Cargo.toml"
+ "vendor/tempfile-3.10.1/Cargo.toml")
+ (("features = \\[\"fs\"" all)
+ (string-append all ", \"use-libc\""))))))))))
+
(define (make-ignore-test-list strs)
"Function to make creating a list to ignore tests a bit easier."
(map (lambda (str)