summaryrefslogtreecommitdiff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
authorNikolai Merinov <nikolai.merinov@member.fsf.org>2018-04-15 10:11:37 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2018-04-16 19:58:04 +0200
commitfe61c88af93a230bee9aebb9c6c3836d153a4e0f (patch)
tree86f53942f6d779bf6447f0d7b6839561b223aafd /gnu/packages/rust.scm
parent1bb23335e63522a558594adf4ab30003eb141e31 (diff)
downloadguix-patches-fe61c88af93a230bee9aebb9c6c3836d153a4e0f.tar
guix-patches-fe61c88af93a230bee9aebb9c6c3836d153a4e0f.tar.gz
gnu: rust: Update to 1.24.0.
* gnu/packages/rust.scm (rust): Rename to... (rust-1.24): ...this. (rust): New variable.
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm24
1 files changed, 23 insertions, 1 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 1112d08440..d95577e45b 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -362,7 +362,7 @@ jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
`("LIBRARY_PATH" ":" suffix (,(string-append libc "/lib"))))
#t)))))))))
-(define-public rust
+(define-public rust-1.24
(let ((base-rust
(rust-bootstrapped-package rust-1.23 "1.24.1"
"1vv10x2h9kq7fxh2v01damdq8pvlp5acyh1kzcda9sfjx12kv99y")))
@@ -373,3 +373,25 @@ jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
((#:phases phases)
`(modify-phases ,phases
(delete 'fix-mtime-bug))))))))
+
+(define-public rust
+ (let ((base-rust rust-1.24))
+ (package
+ (inherit base-rust)
+ (version "1.25.0")
+ (source
+ (rust-source version
+ "0baxjr99311lvwdq0s38bipbnj72pn6fgbk6lcq7j555xq53mxpf"))
+ (native-inputs
+ (alist-replace "cargo-bootstrap" (list base-rust "cargo")
+ (alist-replace "rustc-bootstrap" (list base-rust)
+ (package-native-inputs base-rust))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments base-rust)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'patch-cargo-tests 'patch-cargo-index-update
+ (lambda* _
+ (substitute* "src/tools/cargo/tests/generate-lockfile.rs"
+ ;; This test wants to update the crate index.
+ (("fn no_index_update") "#[ignore]\nfn no_index_update")))))))))))