summaryrefslogtreecommitdiff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
authorZ572 via Guix-patches via <guix-patches@gnu.org>2022-01-22 12:37:10 +0800
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-22 17:03:42 +0100
commitd96f47f012571cdd6dd67c513e496042db303ca7 (patch)
tree076d7bba61b3d7cbf63222025f82c574c5837664 /gnu/packages/rust.scm
parent1c7949080470da968ca7c712fe38654ae3cc174c (diff)
downloadguix-patches-d96f47f012571cdd6dd67c513e496042db303ca7.tar
guix-patches-d96f47f012571cdd6dd67c513e496042db303ca7.tar.gz
gnu: rust-analyzer: Make it work out of the box.base-for-series-11074
* gnu/packages/rust.scm (rust-src): New variable. * gnu/packages/rust-apps.scm (rust-analyzer): [native-inputs]: Add rust-src. [arguments]: <#:phases>: Add wrap-program phase. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 739ffb3192..5a6d4a5c30 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2020 Matthew James Kraai <kraai@ftbfs.org>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 (unmatched parenthesis <paren@disroot.org>
+;;; Copyright © 2022 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -49,6 +50,7 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages)
#:use-module (guix build-system cargo)
+ #:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
#:use-module (guix build-system trivial)
#:use-module (guix download)
@@ -787,3 +789,21 @@ safety and thread safety guarantees.")
;;; be relied upon. This is to ease maintenance and reduce the time
;;; required to build the full Rust bootstrap chain.
(define-public rust rust-1.57)
+
+(define-public rust-src
+ (hidden-package
+ (package
+ (inherit rust)
+ (name "rust-src")
+ (build-system copy-build-system)
+ (native-inputs '())
+ (inputs '())
+ (native-search-paths '())
+ (outputs '("out"))
+ (arguments
+ `(#:install-plan
+ '(("library" "lib/rustlib/src/rust/library")
+ ("src" "lib/rustlib/src/rust/src"))))
+ (synopsis "Source code for the Rust standard library")
+ (description "This package provide source code for the Rust standard
+library, only use by rust-analyzer, make rust-analyzer out of the box."))))