summaryrefslogtreecommitdiff
path: root/gnu/packages/rust-cbindgen.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-10-23 09:47:40 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-10-23 10:31:00 +0300
commit5fafb361c94f3029820314457a7134a429df8404 (patch)
tree60d5443e088a7e168e341f2beac6459739a223b8 /gnu/packages/rust-cbindgen.scm
parent372a6bf0caaea253df995eb08afaf1b9f7843ea9 (diff)
downloadguix-patches-5fafb361c94f3029820314457a7134a429df8404.tar
guix-patches-5fafb361c94f3029820314457a7134a429df8404.tar.gz
gnu: Add rust-libc-0.2.
* gnu/packages/rust-cbindgen.scm (rust-libc-0.2): New hidden variable.
Diffstat (limited to 'gnu/packages/rust-cbindgen.scm')
-rw-r--r--gnu/packages/rust-cbindgen.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/rust-cbindgen.scm b/gnu/packages/rust-cbindgen.scm
index 2f8fe40cd0..e02a023eb1 100644
--- a/gnu/packages/rust-cbindgen.scm
+++ b/gnu/packages/rust-cbindgen.scm
@@ -210,3 +210,32 @@ primitives to an @code{io::Write}.")
(properties '((hidden? . #t)))
(license (list license:asl2.0
license:expat))))
+
+(define rust-libc-0.2
+ (package
+ (name "rust-libc")
+ (version "0.2.65")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "libc" version))
+ (file-name (string-append name "-" version ".crate"))
+ (sha256
+ (base32
+ "1s14bjxnz6haw0gr1h3j4sr7s2s407hpgm8dxhwnl7yzgxia0c8s"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/rust-lang/libc")
+ (synopsis "Raw FFI bindings to platform libraries like libc")
+ (description
+ "libc provides all of the definitions necessary to easily
+interoperate with C code (or \"C-like\" code) on each of the platforms
+that Rust supports. This includes type definitions (e.g., c_int),
+constants (e.g., EINVAL) as well as function headers (e.g., malloc).
+
+This crate exports all underlying platform types, functions, and
+constants under the crate root, so all items are accessible as
+@samp{libc::foo}. The types and values of all the exported APIs match
+the platform that libc is compiled for.")
+ (properties '((hidden? . #t)))
+ (license (list license:expat
+ license:asl2.0))))