summaryrefslogtreecommitdiff
path: root/gnu/packages/rust-apps.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-11-29 14:19:55 +0000
committerChristopher Baines <mail@cbaines.net>2020-11-29 17:34:18 +0000
commitff01206345e2306cc633db48e0b29eab9077091a (patch)
tree25c7ee17005dadc9bf4fae3f0873e03a4704f782 /gnu/packages/rust-apps.scm
parented2545f0fa0e2ad99d5a0c45f532c539b299b9fb (diff)
parent7c2e67400ffaef8eb6f30ef7126c976ee3d7e36c (diff)
downloadguix-patches-ff01206345e2306cc633db48e0b29eab9077091a.tar
guix-patches-ff01206345e2306cc633db48e0b29eab9077091a.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/rust-apps.scm')
-rw-r--r--gnu/packages/rust-apps.scm18
1 files changed, 4 insertions, 14 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index fabb4e0380..33f1806880 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -75,11 +75,6 @@
(("rust-datetime" ,rust-datetime-0.4))
#:phases
(modify-phases %standard-phases
- (add-after 'configure 'dont-vendor-sources
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((openssl (assoc-ref inputs "openssl")))
- (setenv "OPENSSL_DIR" openssl))
- #t))
;; Ignoring failing tests.
;; Reported in https://github.com/ogham/exa/issues/318
(add-before 'check 'disable-failing-tests
@@ -90,6 +85,7 @@
(substitute* "src/options/view.rs"
(("test!\\(across:.*") "")
+ (("test!\\(cr:.*") "")
(("test!\\(empty:.*") "")
(("test!\\(gracross:.*") "")
(("test!\\(grid:.*") "")
@@ -393,18 +389,12 @@ gitignore rules.")
("rust-lazy-static" ,rust-lazy-static-1)
("rust-regex" ,rust-regex-1)
("rust-serde-json" ,rust-serde-json-1)
- ("rust-tempfile" ,rust-tempfile-3))
- #:phases
- (modify-phases %standard-phases
- (add-after 'configure 'unvendor-libraries-from-crates
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((openssl (assoc-ref inputs "openssl")))
- (setenv "OPENSSL_DIR" openssl))
- #t)))))
+ ("rust-tempfile" ,rust-tempfile-3))))
(native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
`(("libgit2" ,libgit2)
("openssl" ,openssl)
- ("pkg-config" ,pkg-config)
("zlib" ,zlib)))
(home-page "https://tokei.rs")
(synopsis "Count code, quickly")