summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-12 16:50:47 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-12 17:46:23 +0000
commita1eca979fb8da842e73c42f4f53be29b169810f2 (patch)
tree681c7283e412bb8a29c2531c4408b49c3e184764 /gnu/packages/ruby.scm
parent48d86a9ec6d8d2e97da2299ea41a03ef4cdaab83 (diff)
parent371aa5777a3805a3886f3feea5f1960fe3fe4219 (diff)
downloadguix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar
guix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 9dfa5043ed..332a03f96b 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1151,18 +1151,10 @@ structure. Supports custom object formatting via plugins.")
"03a11clhycyn0jhc7g9davpqd83sn60jqwjy1y145ag9sq6sp935"))))
(build-system ruby-build-system)
(arguments
- `(#:phases
+ `(#:tests? #f ; Disable tests since they depend on pandoc behavior
+ ; and there are no upstream releases.
+ #:phases
(modify-phases %standard-phases
- (add-after 'unpack 'disable-failing-tests
- ;; TODO: Remove this phase after ghc-pandoc gets upgraded to 2.9.2+
- ;; (see: https://github.com/xwmx/pandoc-ruby/issues/39).
- (lambda _
- (substitute* "test/test_conversions.rb"
- (("next if from == to.*" all)
- (string-append
- all
- " next if ['plain', 'beamer'].include? to\n")))
- #t))
(add-after 'unpack 'patch-pandoc-path
(lambda* (#:key inputs #:allow-other-keys)
(let ((pandoc (search-input-file inputs "/bin/pandoc")))