summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-09-12 12:20:31 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-09-12 14:04:56 +0300
commit04920dca2aa128b440d4db26cc14b7961416767c (patch)
treef04a724f8778a3f7431e38fa6b52c536468f426a /gnu/packages/ruby.scm
parent0246bf5f80e89da98679f7af41f801c244b796b1 (diff)
downloadguix-patches-04920dca2aa128b440d4db26cc14b7961416767c.tar
guix-patches-04920dca2aa128b440d4db26cc14b7961416767c.tar.gz
gnu: ruby-pandoc-ruby: Adjust test suite.
* gnu/packages/ruby.scm (ruby-pandoc-ruby)[arguments]: Adjust test suite to change in ruby behavior and the test suite.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index cbd16e26e5..b207c04b5d 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1173,14 +1173,18 @@ structure. Supports custom object formatting via plugins.")
(("('|\")pandoc" _ quote)
(string-append quote pandoc))
(("\\^pandoc")
- ".*pandoc"))
- #t)))
+ ".*pandoc")))))
+ (add-after 'unpack 'adjust-tests
+ ;; The tests expect filenames with spaces. Because they don't have
+ ;; spaces the quotes around the output are dropped automatically.
+ (lambda _
+ (substitute* "test/test_pandoc_ruby.rb"
+ (("\\\\\"#\\{file\\.path\\}\\\\\"") "#{file.path}"))))
(add-after 'extract-gemspec 'remove-Gemfile.lock
(lambda _
(delete-file "Gemfile.lock")
(substitute* "pandoc-ruby.gemspec"
- (("Gemfile\\.lock") ""))
- #t)))))
+ (("Gemfile\\.lock") "")))))))
(native-inputs
`(("ruby-mocha" ,ruby-mocha)))
(inputs