summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2021-01-04 01:32:13 +0100
committerChristopher Baines <mail@cbaines.net>2021-02-05 19:37:28 +0000
commitb47c85a50da5ae13b65fd715e51d1090f8250e04 (patch)
treee70503cf325fd48400f090f6573aaff67f66e466 /gnu/packages/ruby.scm
parent45270b1862aaf2e4ae5f9fec00fb4a6dede04196 (diff)
downloadguix-patches-b47c85a50da5ae13b65fd715e51d1090f8250e04.tar
guix-patches-b47c85a50da5ae13b65fd715e51d1090f8250e04.tar.gz
gnu: Add ruby-typhoeus.
* gnu/packages/ruby.scm (ruby-typhoeus): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 2a5d4f0f06..f18c564059 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1484,6 +1484,30 @@ Grammar (PEG) parser generator Domain Specific Language (DSL).")
(home-page "https://github.com/cjheath/treetop")
(license license:expat)))
+(define-public ruby-typhoeus
+ (package
+ (name "ruby-typhoeus")
+ (version "1.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "typhoeus" version))
+ (sha256
+ (base32
+ "1m22yrkmbj81rzhlny81j427qdvz57yk5wbcf3km0nf3bl6qiygz"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; no included tests
+ (propagated-inputs
+ `(("ruby-ethon" ,ruby-ethon)))
+ (synopsis "@code{libcurl} wrapper in Ruby")
+ (description
+ "Like a modern code version of the mythical beast with 100 serpent heads,
+Typhoeus runs HTTP requests in parallel while cleanly encapsulating handling
+logic.")
+ (home-page "https://github.com/typhoeus/typhoeus")
+ (license license:expat)))
+
(define-public ruby-rubocop-performance
(package
(name "ruby-rubocop-performance")