summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-01-13 17:50:17 +0100
committerLudovic Courtès <ludo@gnu.org>2016-01-13 18:18:48 +0100
commit8c986ab12034d67db836a881f57c69754d8073ae (patch)
treebf5183011119695ac549d4cfff4dc2175e659397 /gnu/packages/ruby.scm
parent203795aceaabec0e0e5818e1650ad407d825d1b3 (diff)
parent7a2eed3aac1ecd0bdf293e33a234fad58f2e5f9e (diff)
downloadguix-patches-8c986ab12034d67db836a881f57c69754d8073ae.tar
guix-patches-8c986ab12034d67db836a881f57c69754d8073ae.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm42
1 files changed, 39 insertions, 3 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 2977f94660..fd36f8d694 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -121,7 +121,7 @@ a focus on simplicity and productivity.")
(define-public ruby-2.1
(package (inherit ruby)
- (version "2.1.6")
+ (version "2.1.8")
(source
(origin
(method url-fetch)
@@ -130,7 +130,7 @@ a focus on simplicity and productivity.")
"/ruby-" version ".tar.bz2"))
(sha256
(base32
- "1sbcmbhadcxk0509svwxbm2vvgmpf3xjxr1397bgp9x46nz36lkv"))))
+ "11rkbfc90cg9p9mzg32475alf3ddcn9q8a3ar3fwm5xskic0n395"))))
(arguments
`(#:test-target "test"
#:parallel-tests? #f
@@ -490,7 +490,7 @@ supported: XML Markup and XML Events.")
(setenv "JAVA_HOME" (assoc-ref inputs "jdk"))
#t)))))
(native-inputs
- `(("jdk" ,icedtea7 "jdk")))
+ `(("jdk" ,icedtea "jdk")))
(synopsis "Ruby-to-Java bridge using the Java Native Interface")
(description "RJB is a bridge program that connects Ruby and Java via the
Java Native Interface.")
@@ -2942,3 +2942,39 @@ programs to concentrate on the implementation of network protocols. It can be
used to create both network servers and clients.")
(home-page "http://rubyeventmachine.com")
(license (list license:ruby license:gpl3)))) ; GPLv3 only AFAICT
+
+(define-public ruby-ansi
+ (package
+ (name "ruby-ansi")
+ (version "1.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ ;; Fetch from GitHub as the gem does not contain testing code.
+ (uri (string-append "https://github.com/rubyworks/ansi/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1zdip30hivyipi8hndhb457bhiz033awd00bgrsk5axjrwp6zhly"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Disable testing to break the cycle ansi, ae, ansi, as well as the
+ ;; cycle ansi, qed, ansi. Instead simply test that the library can
+ ;; be require'd.
+ (replace 'check
+ (lambda _
+ (zero? (system* "ruby" "-Ilib" "-r" "ansi")))))))
+ (synopsis "ANSI escape code related libraries")
+ (description
+ "This package is a collection of ANSI escape code related libraries
+enabling ANSI colorization and stylization of console output. Included in the
+library are the @code{Code} module, which defines ANSI codes as constants and
+methods, a @code{Mixin} module for including color methods, a @code{Logger}, a
+@code{ProgressBar}, and a @code{String} subclass. The library also includes a
+@code{Terminal} module which provides information about the current output
+device.")
+ (home-page "http://rubyworks.github.io/ansi")
+ (license license:bsd-2)))