summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-01-27 13:30:23 +0000
committerChristopher Baines <mail@cbaines.net>2019-02-14 21:37:56 +0000
commit6dc21310762a350779e5d183cf5c7494bca201e1 (patch)
tree982204beaf941b2731ef0b54e5632a5e1f7302b2 /gnu/packages/ruby.scm
parent6edabcb20ce7df0133cc5ff77a27f4635dfc7573 (diff)
downloadguix-patches-6dc21310762a350779e5d183cf5c7494bca201e1.tar
guix-patches-6dc21310762a350779e5d183cf5c7494bca201e1.tar.gz
gnu: Add ruby-racc.
Required for ruby-ast and ruby-parser. * gnu/packages/ruby.scm (ruby-racc): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 22aaf29428..d9e2282575 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3677,6 +3677,32 @@ differences (added or removed nodes) between two XML/HTML documents.")
(home-page "https://github.com/postmodern/nokogiri-diff")
(license license:expat))))
+(define-public ruby-racc
+ (package
+ (name "ruby-racc")
+ (version "1.4.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "racc" version))
+ (sha256
+ (base32
+ "00yhs2ag7yy5v83mqvkbnhk9bvsh6mx3808k53n61ddzx446v1zl"))))
+ (build-system ruby-build-system)
+ (native-inputs
+ `(("ruby-hoe" ,ruby-hoe)
+ ("ruby-rake-compiler" ,ruby-rake-compiler)))
+ (synopsis "LALR(1) parser generator for Ruby")
+ (description
+ "Racc is a LALR(1) parser generator. It is written in Ruby itself, and
+generates Ruby program.")
+ (home-page "http://i.loveruby.net/en/projects/racc/")
+ (license (list
+ ;; Generally licensed under the LGPL2.1, and some files also
+ ;; available under the same license as Ruby.
+ license:lgpl2.1
+ license:ruby))))
+
(define-public ruby-rack
(package
(name "ruby-rack")