summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-09 11:49:49 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-11 14:26:58 -0400
commit65a61239517f6b45a8728657d55102d2373fe915 (patch)
tree4066b032aaa48ac36743a2471a664ea4037d64d5 /gnu/packages/ruby.scm
parentb17a48d0353e6b4b6b327564f984e354074a638b (diff)
downloadguix-patches-65a61239517f6b45a8728657d55102d2373fe915.tar
guix-patches-65a61239517f6b45a8728657d55102d2373fe915.tar.gz
gnu: ruby-yard: Disable tests.
YARD is a common dependency in the Ruby world; having it carry extra test dependencies is prone to cause dependency cycles. For example, YARD depends on Asciidoctor, but the latest Asciidoctor requires ruby-cucumber for its test suite, which pulls YARD through many of its dependencies. * gnu/packages/ruby.scm (ruby-yard)[arguments]: Disable tests. [native-inputs]: Remove.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm32
1 files changed, 10 insertions, 22 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 5a41375480..72cdeced43 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6994,35 +6994,23 @@ A modified copy of yajl is used, and included in the package.")
(method git-fetch)
;; Tests do not pass if we build from the distributed gem.
(uri (git-reference
- (url "https://github.com/lsegal/yard")
- (commit (string-append "v" version))))
+ (url "https://github.com/lsegal/yard")
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
"1v48zz8hzazrg79jksj9siys21d2axvzijvkxw2j42zh86syi1wi"))))
(build-system ruby-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- ;; Delete the Gemfile to avoid errors relating to it
- (delete-file "Gemfile")
- ;; $HOME needs to be set to somewhere writeable for tests to run
- (setenv "HOME" "/tmp")
- ;; Run tests without using 'rake' to avoid dependencies.
- (invoke "rspec"))))))
- (native-inputs
- `(("ruby-rspec" ,ruby-rspec)
- ("ruby-rack" ,ruby-rack)
- ("ruby-redcloth" ,ruby-redcloth)
- ("ruby-asciidoc" ,ruby-asciidoctor)))
+ ;; Note: Tests are willfully disabled to alleviate dependency cycle
+ ;; problems.
+ `(#:tests? #f))
(synopsis "Documentation generation tool for Ruby")
- (description
- "YARD is a documentation generation tool for the Ruby programming
-language. It enables the user to generate consistent, usable documentation
-that can be exported to a number of formats very easily, and also supports
-extending for custom Ruby constructs such as custom class level definitions.")
+ (description "YARD is a documentation generation tool for the Ruby
+programming language. It enables the user to generate consistent, usable
+documentation that can be exported to a number of formats very easily, and
+also supports extending for custom Ruby constructs such as custom class level
+definitions.")
(home-page "https://yardoc.org")
(license license:expat)))