summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-01 00:07:17 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-01 00:07:17 -0400
commit4d31fe6b6c5c3758ae93f3d1c599072f5df977c4 (patch)
tree2c29e142e8e93473b8505f735c09c2bbf047e1d5 /gnu/packages/ruby.scm
parentacb288767bb05396ac986edad8537d68a4322dff (diff)
downloadguix-patches-4d31fe6b6c5c3758ae93f3d1c599072f5df977c4.tar
guix-patches-4d31fe6b6c5c3758ae93f3d1c599072f5df977c4.tar.gz
gnu: Add ruby-binding-of-caller.
* gnu/packages/ruby.scm (ruby-binding-of-caller): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index eeb3513b1a..8fb4115aea 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6273,6 +6273,30 @@ navigation capabilities to @code{pry}, using @code{byebug}.")
(home-page "https://github.com/deivid-rodriguez/pry-byebug")
(license license:expat)))
+(define-public ruby-binding-of-caller
+ (package
+ (name "ruby-binding-of-caller")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "binding_of_caller" version))
+ (sha256
+ (base32
+ "05syqlks7463zsy1jdfbbdravdhj9hpj5pv2m74blqpv8bq4vv5g"))))
+ (build-system ruby-build-system)
+ ;; Attempting to run the test suite fails with a rake deprecation error
+ ;; (see: https://github.com/banister/binding_of_caller/issues/76).
+ (arguments '(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-debug-inspector" ,ruby-debug-inspector)))
+ (synopsis "Retrieve the binding of a method's caller")
+ (description "The @code{binding_of_caller} module provides the
+@code{Binding#of_caller} method. It allows accessing bindings from upper
+frames in the call stack and can evaluate code in that context.")
+ (home-page "https://github.com/banister/binding_of_caller")
+ (license license:expat)))
+
(define-public ruby-gherkin
(package
(name "ruby-gherkin")