summaryrefslogtreecommitdiff
path: root/gnu/packages/regex.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-10-10 22:33:28 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-10-10 22:33:28 +0200
commitc01ef97594a8b06e884906a5efbdfacf8ba33dc3 (patch)
tree828b4711c6ad71ab8fc9b6fc8f23f80979c5fe9b /gnu/packages/regex.scm
parent86d02fa8010c053ba980e4c39373b9bf8af0561d (diff)
parent4b8b4418e609b5e0bfb6efbc11ac28deaa437e80 (diff)
downloadguix-patches-c01ef97594a8b06e884906a5efbdfacf8ba33dc3.tar
guix-patches-c01ef97594a8b06e884906a5efbdfacf8ba33dc3.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/regex.scm')
-rw-r--r--gnu/packages/regex.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/regex.scm b/gnu/packages/regex.scm
index f35d3e63aa..a49fd89bf2 100644
--- a/gnu/packages/regex.scm
+++ b/gnu/packages/regex.scm
@@ -85,16 +85,16 @@ Python. It is a C++ library.")
"0n36cgqys59r2gmb7jzbqiwsy790v8nbxk82d2n2saz0rp145ild"))))
(build-system gnu-build-system)
(arguments
- `(#:phases (alist-cons-before
- 'check 'install-locales
- (lambda _
- ;; The tests require the availability of the
- ;; 'en_US.ISO-8859-1' locale.
- (setenv "LOCPATH" (getcwd))
- (zero? (system* "localedef" "--no-archive"
- "--prefix" (getcwd) "-i" "en_US"
- "-f" "ISO-8859-1" "./en_US.ISO-8859-1")))
- %standard-phases)))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'install-locales
+ (lambda _
+ ;; The tests require the availability of the
+ ;; 'en_US.ISO-8859-1' locale.
+ (setenv "LOCPATH" (getcwd))
+ (zero? (system* "localedef" "--no-archive"
+ "--prefix" (getcwd) "-i" "en_US"
+ "-f" "ISO-8859-1" "./en_US.ISO-8859-1")))))))
(synopsis "Approximate regex matching library and agrep utility")
(description "Superset of the POSIX regex API, enabling approximate
matching. Also ships a version of the agrep utility which behaves similar to