summaryrefslogtreecommitdiff
path: root/gnu/packages/rdesktop.scm
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2023-08-09 22:31:02 -0700
committerLudovic Courtès <ludo@gnu.org>2023-08-12 22:41:10 +0200
commit437a705f9cd288507d1bf77582d7a0cc5d1f56c3 (patch)
treea3814ba73244ad7c75b34ba446e4f4b181d20800 /gnu/packages/rdesktop.scm
parent97377e389da711dfd0739a8cb41ba19aad90fa96 (diff)
downloadguix-patches-437a705f9cd288507d1bf77582d7a0cc5d1f56c3.tar
guix-patches-437a705f9cd288507d1bf77582d7a0cc5d1f56c3.tar.gz
gnu: Add xorgxrdp.
* gnu/packages/rdesktop.scm (xorgxrdp): New variable Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/rdesktop.scm')
-rw-r--r--gnu/packages/rdesktop.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/rdesktop.scm b/gnu/packages/rdesktop.scm
index 505c051433..2a969a2f78 100644
--- a/gnu/packages/rdesktop.scm
+++ b/gnu/packages/rdesktop.scm
@@ -209,3 +209,47 @@ variety of RDP clients:
@end itemize")
(license license:asl2.0)))
+(define-public xorgxrdp
+ (package
+ (name "xorgxrdp")
+ (version "0.9.19")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/neutrinolabs/xorgxrdp/releases/download/v"
+ version "/xorgxrdp-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0m8lvdnhfvwwqrr56difgy3mblplp23x6iy12kl4r8i87ic4rky1"))))
+ (build-system gnu-build-system)
+ (inputs (list check
+ imlib2
+ libx11
+ libxfixes
+ libxfont2
+ libxml2
+ libxpm
+ libxrandr
+ libxslt
+ libxt
+ pixman
+ xdpyinfo
+ xorg-server
+ xrdp))
+ (native-inputs (list nasm
+ intltool
+ pkg-config
+ pixman))
+ (arguments
+ (list #:configure-flags #~(list "--enable-strict-locations=yes"
+ (string-append "XRDP_CFLAGS=-I"
+ #$(this-package-input
+ "xrdp") "/common"))))
+ (home-page "https://github.com/neutrinolabs/xorgxrdp")
+ (synopsis "Xorg drivers for xrdp")
+ (description
+ "xorgxrdp is a collection of modules to be used with a pre-existing X.Org
+install to make the X server act like X11rdp. Unlike X11rdp, you don't have to
+recompile the whole X Window System. Instead, additional modules are installed
+to a location where the existing Xorg installation would pick them.")
+ (license license:x11)))