summaryrefslogtreecommitdiff
path: root/gnu/packages/radio.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2024-02-15 23:10:42 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2024-02-15 23:10:42 +0100
commitbd87416648929f38c0173f047776d7675ea8a10d (patch)
tree9c206b7bbc3c06b1af09abd0dbcc4daf954ed23d /gnu/packages/radio.scm
parentf01d53d5afd78e9cef505aaf69221cfed3b05702 (diff)
downloadguix-patches-bd87416648929f38c0173f047776d7675ea8a10d.tar
guix-patches-bd87416648929f38c0173f047776d7675ea8a10d.tar.gz
gnu: Add dumpvdl2.
* gnu/packages/radio.scm (dumpvdl2): New variable. Change-Id: I0d4fb449f8e01d6b8fe44d2132a6cc10e9cd41b5
Diffstat (limited to 'gnu/packages/radio.scm')
-rw-r--r--gnu/packages/radio.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 69452f340c..2f258b0364 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -99,6 +99,7 @@
#:use-module (gnu packages sdl)
#:use-module (gnu packages serialization)
#:use-module (gnu packages sphinx)
+ #:use-module (gnu packages sqlite)
#:use-module (gnu packages swig)
#:use-module (gnu packages tcl)
#:use-module (gnu packages tex)
@@ -1914,6 +1915,36 @@ ACARS messages used by planes.")
(license (list license:bsd-2
license:expat))))
+(define-public dumpvdl2
+ (package
+ (name "dumpvdl2")
+ (version "2.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/szpajder/dumpvdl2")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zxv24fg2ciy7bfiqhx95v0h8b1bnbs3ax06n9ywsssbf4ndas4n"))))
+ (build-system cmake-build-system)
+ (native-inputs (list pkg-config))
+ (inputs
+ (list glib
+ libacars
+ protobuf-c
+ rtl-sdr
+ soapysdr
+ sqlite
+ zeromq))
+ (arguments (list #:tests? #f)) ; No test suite
+ (synopsis "VDL Mode 2 message decoder")
+ (description "This package provides a decoder for VDL Mode 2 messages used
+by planes.")
+ (home-page "https://github.com/szpajder/dumpvdl2")
+ (license license:gpl3+)))
+
(define-public rtl-433
(package
(name "rtl-433")