summaryrefslogtreecommitdiff
path: root/gnu/packages/qemu.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-06-15 23:57:14 -0400
committerMark H Weaver <mhw@netris.org>2015-06-16 00:29:28 -0400
commitfef3cfaaab972b1f514724f90050aeb38516519b (patch)
tree89d58b467be5e59263c1f41d06dfa4e08187eaf3 /gnu/packages/qemu.scm
parent77ff9e9a994a3a23d973d87456a0085ac53b23bc (diff)
downloadguix-patches-fef3cfaaab972b1f514724f90050aeb38516519b.tar
guix-patches-fef3cfaaab972b1f514724f90050aeb38516519b.tar.gz
gnu: qemu: Add fixes for CVE-2015-{4037,4103,4104,4105,4106}.
* gnu/packages/patches/qemu-CVE-2015-4037.patch, gnu/packages/patches/qemu-CVE-2015-4103.patch, gnu/packages/patches/qemu-CVE-2015-4104.patch, gnu/packages/patches/qemu-CVE-2015-4105.patch, gnu/packages/patches/qemu-CVE-2015-4106-pt1.patch, gnu/packages/patches/qemu-CVE-2015-4106-pt2.patch, gnu/packages/patches/qemu-CVE-2015-4106-pt3.patch, gnu/packages/patches/qemu-CVE-2015-4106-pt4.patch, gnu/packages/patches/qemu-CVE-2015-4106-pt5.patch, gnu/packages/patches/qemu-CVE-2015-4106-pt6.patch, gnu/packages/patches/qemu-CVE-2015-4106-pt7.patch, gnu/packages/patches/qemu-CVE-2015-4106-pt8.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/qemu.scm (qemu-headless)[source]: Add patches.
Diffstat (limited to 'gnu/packages/qemu.scm')
-rw-r--r--gnu/packages/qemu.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/qemu.scm b/gnu/packages/qemu.scm
index 27a2d2e8ba..9213007452 100644
--- a/gnu/packages/qemu.scm
+++ b/gnu/packages/qemu.scm
@@ -53,7 +53,19 @@
(base32
"120m53c3p28qxmfzllicjzr8syjv6v4d9rsyrgkp7gnmcgvvgfmn"))
(patches (map search-patch '("qemu-CVE-2015-3209.patch"
- "qemu-CVE-2015-3456.patch")))))
+ "qemu-CVE-2015-3456.patch"
+ "qemu-CVE-2015-4037.patch"
+ "qemu-CVE-2015-4103.patch"
+ "qemu-CVE-2015-4104.patch"
+ "qemu-CVE-2015-4105.patch"
+ "qemu-CVE-2015-4106-pt1.patch"
+ "qemu-CVE-2015-4106-pt2.patch"
+ "qemu-CVE-2015-4106-pt3.patch"
+ "qemu-CVE-2015-4106-pt4.patch"
+ "qemu-CVE-2015-4106-pt5.patch"
+ "qemu-CVE-2015-4106-pt6.patch"
+ "qemu-CVE-2015-4106-pt7.patch"
+ "qemu-CVE-2015-4106-pt8.patch")))))
(build-system gnu-build-system)
(arguments
'(#:phases (alist-replace