summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 21:36:49 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 23:37:05 -0400
commit97e37a8a79d8f430f3023ebec49277b9cb65468a (patch)
tree22836ed4eb1d1fc2850bf8f6b359e7974463d8d9 /gnu/packages/python.scm
parentca0e4a4b5e4c1c65a3ac080e520f61293e3a9b7a (diff)
downloadguix-patches-97e37a8a79d8f430f3023ebec49277b9cb65468a.tar
guix-patches-97e37a8a79d8f430f3023ebec49277b9cb65468a.tar.gz
gnu: wrap-python3: Replace assoc-ref call with gexp variable.
* gnu/packages/python.scm (wrap-python3) [arguments]: Replace assoc-ref call with gexp variable in builder.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm4
1 files changed, 1 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3e3074d5d8..bfe8a68352 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -639,9 +639,7 @@ for more information.")))
#:builder
#~(begin
(use-modules (guix build utils))
-
- ;; TODO: Remove 'assoc-ref' uses on next rebuild cycle.
- (let ((bin (string-append (assoc-ref %outputs "out") "/bin"))
+ (let ((bin (string-append #$output "/bin"))
(python (string-append
;; XXX: '%build-inputs' contains the native
;; Python when cross-compiling.