summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-11 09:03:30 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-19 22:27:03 +0200
commite7304ab18b8c2b6381cc62264fa82d2b4acf4b59 (patch)
treeb54ce2d78389baa637bac877e19574fb61dd2271 /gnu/packages/python.scm
parent5f94ec913f9bfda05aa8a5e7993ff95c38d23a08 (diff)
downloadguix-patches-e7304ab18b8c2b6381cc62264fa82d2b4acf4b59.tar
guix-patches-e7304ab18b8c2b6381cc62264fa82d2b4acf4b59.tar.gz
gnu: Add python-sphinx-1.6.
* gnu/packages/python.scm (python-sphinx-1.6): New variable.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e5fd71ef1b..d3832f30fb 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3236,6 +3236,36 @@ sources.")
(license license:bsd-3)
(properties `((python2-variant . ,(delay python2-sphinx))))))
+(define-public python-sphinx-1.6
+ (package (inherit python-sphinx)
+ (name "python-sphinx")
+ (version "1.6.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "Sphinx" version))
+ (sha256
+ (base32
+ "1rj6f3i8hmrx2qlkshi5kp5xcy98dlynwlyl05yvflj5f66dp2xg"))))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ ;; Requires Internet access.
+ (delete-file "tests/test_build_linkcheck.py")
+ (substitute* "tests/test_build_latex.py"
+ (("@pytest.mark.sphinx\\('latex', testroot='images'\\)")
+ "@pytest.mark.skip()"))
+ (zero? (system* "make" "test")))))))
+ (propagated-inputs
+ `(("python-sphinxcontrib-websupport" ,python-sphinxcontrib-websupport)
+ ,@(package-propagated-inputs python-sphinx)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest-3.0)
+ ("imagemagick" ,imagemagick) ; for "convert"
+ ,@(package-native-inputs python-sphinx)))
+ (properties '())))
+
(define-public python-sphinx-1.5.3
(package
(inherit python-sphinx)