summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-08-17 06:45:05 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-08-17 06:46:06 +0300
commite3b861ce3845d63e6751f3b35f289ddb9624f8e8 (patch)
tree140f00a70394eae348fc5761ae0c398238b26ea5 /gnu/packages/python.scm
parentd6ef422fe72a188361cf1779d27934a7787ad3d2 (diff)
downloadguix-patches-e3b861ce3845d63e6751f3b35f289ddb9624f8e8.tar
guix-patches-e3b861ce3845d63e6751f3b35f289ddb9624f8e8.tar.gz
gnu: python-cython: Update to 0.26.
* gnu/packages/python.scm (python-cython, python2-cython): Update to 0.26. [source]: Remove patch. * gnu/packages/patches/python-cython-fix-tests-32bit.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3f5b5b980d..29bb4936bc 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3607,15 +3607,14 @@ is designed to have a low barrier to entry.")
(define-public python-cython
(package
(name "python-cython")
- (version "0.25.2")
+ (version "0.26")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Cython" version))
- (patches (search-patches "python-cython-fix-tests-32bit.patch"))
(sha256
(base32
- "01h3lrf6d98j07iakifi81qjszh6faa37ibx7ylva1vsqbwx2hgi"))))
+ "0riciynnr0r68cvg6r3gbhi9x7h44pdwb7926m6n5vfs5p1f492c"))))
(build-system python-build-system)
;; we need the full python package and not just the python-wrapper
;; because we need libpython3.3m.so
@@ -3626,7 +3625,7 @@ is designed to have a low barrier to entry.")
(modify-phases %standard-phases
(add-before 'check 'set-HOME
;; some tests require access to "$HOME/.cython"
- (lambda _ (setenv "HOME" "/tmp")))
+ (lambda _ (setenv "HOME" "/tmp") #t))
(replace 'check
(lambda _ (zero? (system* "python" "runtests.py" "-vv")))))))
(home-page "http://cython.org/")