summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-08-11 20:45:54 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2017-08-12 16:30:16 +0200
commit462ae6f612a251128445c1fa465ededf9b8f6281 (patch)
tree5da804ad4c1803a52baca048d0d14fd1c6bfb37a /gnu/packages/python.scm
parentbfcdf88760e6732d43c0cd1eeb0a95c5d8681950 (diff)
downloadguix-patches-462ae6f612a251128445c1fa465ededf9b8f6281.tar
guix-patches-462ae6f612a251128445c1fa465ededf9b8f6281.tar.gz
gnu: python-pylint: Use Python2 variant system.
* gnu/packages/python.scm (python-pylint): Use Python2 variant system. (python2-pylint): Strip Python2 variant system.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 731fee6333..13e1ce5bcb 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14322,10 +14322,12 @@ Pylint has many rules enabled by default, way too much to silence them
all on a minimally sized program. It's highly configurable and handle
pragmas to control it from within your code. Additionally, it is
possible to write plugins to add your own checks.")
+ (properties `((python2-variant . ,(delay python2-pylint))))
(license license:gpl2+)))
(define-public python2-pylint
- (let ((pylint (package-with-python2 python-pylint)))
+ (let ((pylint (package-with-python2
+ (strip-python2-variant python-pylint))))
(package (inherit pylint)
(propagated-inputs
`(("python2-backports-functools-lru-cache"