summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-17 01:22:48 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:57 +0100
commit38ceb106bd12bcf52f5d277d93393f284c83cc1f (patch)
tree5135a249d382fe6deded20aeb96a963e3675c46a /gnu/packages/python.scm
parent4e0969686cf005105b5a2f9718f0a2bdde9a6b4c (diff)
downloadguix-patches-38ceb106bd12bcf52f5d277d93393f284c83cc1f.tar
guix-patches-38ceb106bd12bcf52f5d277d93393f284c83cc1f.tar.gz
gnu: python-nautilus: Correct inputs
* gnu/packages/python.scm(python-nautilus, python2-nautilus): [propagated-inputs] remove python-graphql-core, python-graphql-relay, python-requests: not listed and already propagated by others. Remove pycparser: not listed, not used in source. Move python-nose2 to [native-inputs] (used for tests only).
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f3a5ddf6ce..0d7fcf1c86 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -11268,17 +11268,14 @@ with an associated set of resolve methods that know how to fetch data.")
`(("python-bcrypt" ,python-bcrypt)
("python-click" ,python-click)
("python-consul" ,python-consul)
- ("python-graphql-core" ,python-graphql-core)
- ("python-graphql-relay" ,python-graphql-relay)
("python-graphene" ,python-graphene)
("python-jinja2" ,python-jinja2)
- ("python-nose2" ,python-nose2)
("python-peewee" ,python-peewee)
("python-pika" ,python-pika)
- ("python-pycparser" ,python-pycparser)
- ("python-requests" ,python-requests)
("python-tornado" ,python-tornado)
("python-wtforms" ,python-wtforms)))
+ (native-inputs
+ `(("python-nose2" ,python-nose2)))
(home-page "https://github.com/AlecAivazis/nautilus")
(synopsis "Library for creating microservice applications")
(description