summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorhumanitiesNerd <catonano@gmail.com>2017-03-12 20:44:47 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-03-13 19:36:54 +0100
commit35db2d3cb766401fa90041cd3ec8248dcbd8d3b5 (patch)
treeb0b1e096e58212886488662400f4b493fd16eb8a /gnu/packages/python.scm
parent1bbbb0b4af95f20ea09d9f348a5fc8c09048b208 (diff)
downloadguix-patches-35db2d3cb766401fa90041cd3ec8248dcbd8d3b5.tar
guix-patches-35db2d3cb766401fa90041cd3ec8248dcbd8d3b5.tar.gz
gnu: Add python-htmlmin.
* gnu/packages/python.scm (python-htmlmin, python2-htmlmin): New variables. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ee785c26ed..d77014d5c6 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -36,6 +36,7 @@
;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017 Carlo Zancanaro <carlo@zancanaro.id.au>
;;; Copyright © 2017 Frederick M. Muriithi <fredmanglis@gmail.com>
+;;; Copyright © 2017 humanitiesNerd <catonano@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -13598,3 +13599,26 @@ The distinctive feature of this B-tree is that a node is never
copy-on-write. This makes it easy to clone a tree, and modify only the
clone, while other processes access the original tree.")
(license license:gpl3+)))
+
+(define-public python-htmlmin
+ (package
+ (name "python-htmlmin")
+ (version "0.1.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "htmlmin" version))
+ (sha256
+ (base32
+ "0qxa93j3p1ak32qh8d9kshqv8v3z0hkc13dwbhp5cn7sn3xmsp6a"))))
+ (arguments
+ `(#:tests? #f)) ;htmlmin has no tests
+ (build-system python-build-system)
+ (home-page "https://htmlmin.readthedocs.org/en/latest/")
+ (synopsis "HTML minifier")
+ (description "@code{htmlmin} is an HTML minifier that just works.
+It comes with safe defaults and easily configurable options.")
+ (license license:bsd-3)))
+
+(define-public python2-htmlmin
+ (package-with-python2 python-htmlmin))