summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-09-23 12:46:24 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-10-12 16:08:18 +0200
commit6784f2e3fe744c7b67130f9136ec769e7b05f59f (patch)
tree8772d6fffdc8f00cc8f851b1cfdb50d82db3e3c3 /gnu/packages/python.scm
parent229ad120d473360c1e575529c0e105f76a0add54 (diff)
downloadguix-patches-6784f2e3fe744c7b67130f9136ec769e7b05f59f.tar
guix-patches-6784f2e3fe744c7b67130f9136ec769e7b05f59f.tar.gz
gnu: Add python-pytest-runner.
* gnu/packages/python.scm (python-pytest-runner, python2-pytest-runner): New variables.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index bf21e9aa99..307b888819 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1549,6 +1549,44 @@ and many external plugins.")
(define-public python2-pytest
(package-with-python2 python-pytest))
+(define-public python-pytest-runner
+ (package
+ (name "python-pytest-runner")
+ (version "2.6.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pypi.python.org/packages/source/p/"
+ "pytest-runner/pytest-runner-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1nwcqx0l3fv52kv8526wy8ypzghbq96c96di318d98d3wh7a8xg7"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; The fancy way of setting the version with setuptools_scm does not
+ ;; seem to work here.
+ (add-after 'unpack 'set-version
+ (lambda _
+ (substitute* "docs/conf.py"
+ (("version = setuptools_scm\\.get_version\\(root='\\.\\.')")
+ (string-append "version = \"" ,version "\"")))
+ #t)))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-setuptools-scm" ,python-setuptools-scm)))
+ (home-page "https://bitbucket.org/pytest-dev/pytest-runner")
+ (synopsis "Invoke py.test as a distutils command")
+ (description
+ "This package provides a @command{pytest-runner} command that
+@file{setup.py} files can use to run tests.")
+ (license license:expat)))
+
+(define-public python2-pytest-runner
+ (package-with-python2 python-pytest-runner))
+
(define-public python-scripttest
(package
(name "python-scripttest")