summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2013-04-06 00:28:39 +0200
committerLudovic Courtès <ludo@gnu.org>2013-04-12 21:58:46 +0200
commit3fdc99da1933e07985b6ca04d3b9412d5df05ade (patch)
treee587e3fce8649bdf0ab9481b7299ddb114279c93 /gnu/packages/python.scm
parentf0cd71f21e41d5a638b69ecee0fa3939f27a4502 (diff)
downloadguix-patches-3fdc99da1933e07985b6ca04d3b9412d5df05ade.tar
guix-patches-3fdc99da1933e07985b6ca04d3b9412d5df05ade.tar.gz
gnu: Python: fix the compilation of some modules from the standard library.
This commit enables the bz2, dbm, readline, ssl and zlib modules. * gnu/packages/gdbm.scm: Enable the compatibility mode. * gnu/packages/python.scm: Enable a few modules from the standard library. * gnu/packages/patches/python-fix-dbm.patch: New file. * Makefile.am: Add it.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm33
1 files changed, 30 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 26b76864ce..30bb8e22f7 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -19,7 +19,10 @@
(define-module (gnu packages python)
#:use-module ((guix licenses) #:select (psfl))
+ #:use-module (gnu packages)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages gdbm)
+ #:use-module (gnu packages readline)
#:use-module (gnu packages openssl)
#:use-module (guix packages)
#:use-module (guix download)
@@ -38,11 +41,35 @@
(base32
"11f9aw855lrmknr6c82gm1ijr3n0smc6idyp94y7774yivjnplv1"))))
(build-system gnu-build-system)
- (arguments `(#:tests? #f)) ; XXX: some tests fail
+ (arguments
+ `(#:tests? #f ; XXX: some tests fail
+ #:patches (list (assoc-ref %build-inputs "patch-dbm"))
+ #:patch-flags '("-p0")
+ #:configure-flags
+ (let ((bz2 (assoc-ref %build-inputs "bzip2"))
+ (gdbm (assoc-ref %build-inputs "gdbm"))
+ (openssl (assoc-ref %build-inputs "openssl"))
+ (readline (assoc-ref %build-inputs "readline"))
+ (zlib (assoc-ref %build-inputs "zlib")))
+ (list (string-append "CPPFLAGS="
+ "-I" bz2 "/include "
+ "-I" gdbm "/include "
+ "-I" openssl "/include "
+ "-I" readline "/include "
+ "-I" zlib "/include")
+ (string-append "LDFLAGS="
+ "-L" bz2 "/lib "
+ "-L" gdbm "/lib "
+ "-L" openssl "/lib "
+ "-L" readline "/lib "
+ "-L" zlib "/lib")))))
(inputs
- `(("zlib" ,zlib)
+ `(("bzip2" ,bzip2)
+ ("gdbm" ,gdbm)
("openssl" ,openssl)
- ("bzip2" ,bzip2)))
+ ("readline" ,readline)
+ ("zlib" ,zlib)
+ ("patch-dbm" ,(search-patch "python-fix-dbm.patch"))))
(native-search-paths
(list (search-path-specification
(variable "PYTHONPATH")