summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2013-04-15 22:02:47 +0200
committerCyril Roelandt <tipecaml@gmail.com>2013-04-16 23:12:29 +0200
commit0160536dcb5399ad7d80b10e064df5c95f3adb4f (patch)
tree2f05ac8e60228dee8b294811e5de300269747605 /gnu/packages/python.scm
parente967678ed1f1d7e765adc4bfc7d2a79ee9677b21 (diff)
downloadguix-patches-0160536dcb5399ad7d80b10e064df5c95f3adb4f.tar
guix-patches-0160536dcb5399ad7d80b10e064df5c95f3adb4f.tar.gz
gnu: Python: bump to version 2.7.4.
* gnu/packages/python.scm: bump to version 2.7.4, remove references to python-fix-dbm.patch. * Makefile.am: remove references to python-fix-dbm.patch * gnu/packages/patches/python-fix-dbm.patch: remove it.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3f941642fc..8b4515930e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -31,7 +31,7 @@
(define-public python
(package
(name "python")
- (version "2.7.3")
+ (version "2.7.4")
(source
(origin
(method url-fetch)
@@ -39,12 +39,10 @@
version "/Python-" version ".tar.xz"))
(sha256
(base32
- "11f9aw855lrmknr6c82gm1ijr3n0smc6idyp94y7774yivjnplv1"))))
+ "0bdn4dylm92n2dsvqvjfyask9jbz88aan5hi4lgkawkxs2v6wqmn"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; XXX: some tests fail
- #:patches (list (assoc-ref %build-inputs "patch-dbm"))
- #:patch-flags '("-p0")
#:configure-flags
(let ((bz2 (assoc-ref %build-inputs "bzip2"))
(gdbm (assoc-ref %build-inputs "gdbm"))
@@ -68,8 +66,7 @@
("gdbm" ,gdbm)
("openssl" ,openssl)
("readline" ,readline)
- ("zlib" ,zlib)
- ("patch-dbm" ,(search-patch "python-fix-dbm.patch"))))
+ ("zlib" ,zlib)))
(home-page "http://python.org")
(synopsis
"Python, a high-level dynamically-typed programming language")