summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-06-07 21:52:42 +0800
committer宋文武 <iyzsong@gmail.com>2016-06-11 12:53:09 +0800
commitd951bd547cd9aadb16c1d324985055822cee50fc (patch)
tree966e75bb84a885e07d0b663f0bcb599f4a681a76 /gnu/packages/python.scm
parent2c1286f48b0a6e09a11cc4d1ea173ea8340625a6 (diff)
downloadguix-patches-d951bd547cd9aadb16c1d324985055822cee50fc.tar
guix-patches-d951bd547cd9aadb16c1d324985055822cee50fc.tar.gz
gnu: Add python-tabulate and python2-tabulate.
* gnu/packages/python.scm (python-tabulate, python2-tabulate): New variables.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 143fc144b6..70e44416c9 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9037,3 +9037,35 @@ It uses LR parsing and does extensive error checking.")
(inherit (package-with-python2
(strip-python2-variant python-ply)))
(native-inputs `(("python2-setuptools" ,python2-setuptools)))))
+
+(define-public python-tabulate
+ (package
+ (name "python-tabulate")
+ (version "0.7.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "tabulate" version))
+ (sha256
+ (base32
+ "03l1r7ddd1a0j2snv1yd0hlnghjad3fg1an1jr8936ksv75slwch"))
+ ;; Fix tests
+ (modules '((guix build utils)))
+ (snippet '(substitute* '("test/test_cli.py"
+ "test/test_input.py"
+ "test/test_output.py"
+ "test/test_regression.py")
+ (("from common") "from nose.tools")))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)
+ ;; For testing
+ ("python-nose" ,python-nose)))
+ (home-page "https://bitbucket.org/astanin/python-tabulate")
+ (synopsis "Pretty-print tabular data")
+ (description
+ "Tabulate is a library and command-line utility to pretty-print tabular
+data in Python.")
+ (license license:expat)))
+
+(define-public python2-tabulate
+ (package-with-python2 python-tabulate))