summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-06-04 14:40:50 +0800
committer宋文武 <iyzsong@gmail.com>2016-06-04 15:07:03 +0800
commit68b9d2422cfceef459e8bee6833e19ff5608d3f4 (patch)
tree2fa837d6f5f0ba7c3af040ee47435abb225d688e /gnu/packages/python.scm
parent85de436530b81ecdcd6fe1a079d734340c8170b9 (diff)
downloadguix-patches-68b9d2422cfceef459e8bee6833e19ff5608d3f4.tar
guix-patches-68b9d2422cfceef459e8bee6833e19ff5608d3f4.tar.gz
gnu: Add python-greenlet and python2-greenlet.
* gnu/packages/python.scm (python-greenlet, python2-greenlet): New variables.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 332018321f..2abf6bedce 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8916,3 +8916,28 @@ provides support for parsing, splitting and formatting SQL statements.")
(define-public python2-sqlparse
(package-with-python2 python-sqlparse))
+
+(define-public python-greenlet
+ (package
+ (name "python-greenlet")
+ (version "0.4.9")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "greenlet" version))
+ (sha256
+ (base32
+ "04h0m54dyqg49vyarq26mry6kbivnpl47rnmmrk9qn8wpfxviybr"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "https://greenlet.readthedocs.io/")
+ (synopsis "Lightweight in-process concurrent programming")
+ (description
+ "Greenlet package is a spin-off of Stackless, a version of CPython
+that supports micro-threads called \"tasklets\". Tasklets run
+pseudo-concurrently (typically in a single or a few OS-level threads) and
+are synchronized with data exchanges on \"channels\".")
+ (license (list psfl license:expat))))
+
+(define-public python2-greenlet
+ (package-with-python2 python-greenlet))