summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-05-29 19:00:35 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-01 22:42:35 +0200
commit4a23818659b0f46f5730d9501e7cfe87cc81e45a (patch)
tree534448444e826fba2a53afb1c74f4326268d1a06 /gnu/packages/python.scm
parent1a024de45e0fe57342d3cec3ba54e129976fd914 (diff)
downloadguix-patches-4a23818659b0f46f5730d9501e7cfe87cc81e45a.tar
guix-patches-4a23818659b0f46f5730d9501e7cfe87cc81e45a.tar.gz
gnu: Add python2-ipaddr.
* gnu/packages/python.scm: (python2-ipaddr): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 642fbd6ffe..332018321f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5788,6 +5788,35 @@ IPv6 addresses and networks. This is a port of the Python 3.3 ipaddress
module to older versions of Python.")
(license psfl)))
+(define-public python2-ipaddr
+ (package
+ (name "python2-ipaddr")
+ (version "2.1.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ipaddr" version))
+ (sha256
+ (base32 "1dwq3ngsapjc93fw61rp17fvzggmab5x1drjzvd4y4q0i255nm8v"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2 ;version 2 only
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* _
+ (zero? (system* "python" "ipaddr_test.py")))))))
+ (home-page "https://github.com/google/ipaddr-py")
+ (synopsis "IP address manipulation library")
+ (description
+ "Ipaddr is a Python@tie{}2 library for creating and manupilating IPv4 and
+IPv6 addresses and networks.
+
+For new implementations you may prefer to use the standard module
+@code{ipaddress}, which was introduced in Python 3.3 and backported to older
+versions of Python.")
+ (license asl2.0)))
+
(define-public python-idna
(package
(name "python-idna")