summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-05-10 09:04:40 +0200
committerLudovic Courtès <ludo@gnu.org>2016-05-10 16:50:46 +0200
commit216c283b0adf0357032019ff73b5d14cff109612 (patch)
tree71f3efa4c435fd553b8403119ea814460a38c031 /gnu/packages/python.scm
parent9ffe61b0ee38b0df88868706d5918e944a626cd9 (diff)
downloadguix-patches-216c283b0adf0357032019ff73b5d14cff109612.tar
guix-patches-216c283b0adf0357032019ff73b5d14cff109612.tar.gz
gnu: python: Make sure shared libraries are stripped.
* gnu/packages/python.scm (python-2)[arguments]: Add 'make-libraries-writable' phase.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f09ff9694f..adef5e6529 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -223,6 +223,15 @@
file))))))
(call-with-output-file "__init__.py" (const #t))
#t)))))))
+ (add-before 'strip 'make-libraries-writable
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Make .so files writable so they can be stripped.
+ (let ((out (assoc-ref outputs "out")))
+ (for-each (lambda (file)
+ (chmod file #o755))
+ (find-files (string-append out "/lib")
+ "\\.so"))
+ #t)))
(add-after 'install 'move-tk-inter
(lambda* (#:key outputs #:allow-other-keys)
;; When Tkinter support is built move it to a separate output so