summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-04-28 19:18:26 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-04-28 19:43:21 +0300
commit0848d8d3a6ec958dda620ae52e2fc4b735b54e37 (patch)
tree87ca642a1db06e8af43b9e5e3146d26aca2cbbde /gnu/packages/python.scm
parentf28cb89e4831ad2bbb1bc3131be3e23149facfad (diff)
downloadguix-patches-0848d8d3a6ec958dda620ae52e2fc4b735b54e37.tar
guix-patches-0848d8d3a6ec958dda620ae52e2fc4b735b54e37.tar.gz
gnu: python-rauth: Rearrange inputs.
* gnu/packages/python.scm (python-rauth)[native-inputs]: Remove it. [propagated-inputs]: Move python-requests ... [inputs]: ... to here. [properties]: Define python2-variant. (python2-rauth): Build with 'strip-python2-variant'. [native-inputs]: Add python2-setuptools.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f79fd744be..f37fc56a80 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7212,9 +7212,7 @@ Python at your fingertips, in Lisp form.")
(build-system python-build-system)
(arguments
`(#:test-target "check"))
- (native-inputs
- `(("python-setuptools" ,python-setuptools)))
- (propagated-inputs
+ (inputs
`(("python-requests" ,python-requests)))
(home-page "https://github.com/litl/rauth")
(synopsis "Python library for OAuth 1.0/a, 2.0, and Ofly")
@@ -7222,15 +7220,16 @@ Python at your fingertips, in Lisp form.")
"Rauth is a Python library for OAuth 1.0/a, 2.0, and Ofly. It also
provides service wrappers for convenient connection initialization and
authenticated session objects providing things like keep-alive.")
- (license license:expat)))
+ (license license:expat)
+ (properties `((python2-variant . ,(delay python2-rauth))))))
(define-public python2-rauth
- (let ((rauth (package-with-python2 python-rauth)))
- (package (inherit rauth)
- (propagated-inputs `(("python2-requests" ,python2-requests)))
- (native-inputs
- `(("python2-unittest2" ,python2-unittest2)
- ,@(package-native-inputs rauth))))))
+ (let ((base (package-with-python2 (strip-python2-variant python-rauth))))
+ (package
+ (inherit base)
+ (native-inputs `(("python2-setuptools" ,python2-setuptools)
+ ("python2-unittest2" ,python2-unittest2)
+ ,@(package-native-inputs base))))))
(define-public python2-functools32
(package