summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2017-08-11 03:49:24 -0400
committerMark H Weaver <mhw@netris.org>2017-08-11 03:49:24 -0400
commit3785e42e5219a86d9d8a5208ff18e97e0cbcbe78 (patch)
treeb4204645ec27c08735604b5043be44550f4d704e /gnu/packages/python.scm
parentd156c999d0e7413696064992bb4a001d2d95317d (diff)
parentd373c16f33fe0735a7a7d24899530c1af255b5f6 (diff)
downloadguix-patches-3785e42e5219a86d9d8a5208ff18e97e0cbcbe78.tar
guix-patches-3785e42e5219a86d9d8a5208ff18e97e0cbcbe78.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 90a7dc661b..f5f89c9e06 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6565,6 +6565,29 @@ connection to each user.")
("python2-singledispatch" ,python2-singledispatch)
,@(package-propagated-inputs tornado))))))
+(define-public python-tornado-http-auth
+ (package
+ (name "python-tornado-http-auth")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "tornado-http-auth" version))
+ (sha256
+ (base32
+ "0znrgqd7k2s4ia474xizi6h3061zj4sn5n6cq76bkwl3wwshifn5"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-tornado" ,python-tornado)))
+ (home-page
+ "https://github.com/gvalkov/tornado-http-auth")
+ (synopsis
+ "Digest and basic authentication module for Tornado")
+ (description
+ "Provides support for adding authentication to services using the Tornado
+web framework, either via the basic or digest authentication schemes.")
+ (license license:asl2.0)))
+
;; the python- version can be removed with python-3.5
(define-public python-backports-abc
(package