summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-09-05 15:54:51 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-09-10 16:50:25 +0200
commit943a4cb60158c28da1348e3b490e958551557d6a (patch)
tree446291b8e92b60a33263d18d570a2210b7834259 /gnu/packages/python.scm
parentfc6256725174ec726caa05a33116b64974037509 (diff)
downloadguix-patches-943a4cb60158c28da1348e3b490e958551557d6a.tar
guix-patches-943a4cb60158c28da1348e3b490e958551557d6a.tar.gz
gnu: Add python-multiprocess.
* gnu/packages/python.scm (python-multiprocess): New variable.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 6f9a557c36..59b62fec14 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14045,3 +14045,25 @@ interpreter session, close the interpreter, ship the pickled file to another
computer, open a new interpreter, unpickle the session and thus continue from
the saved state of the original interpreter session.")
(license license:bsd-3)))
+
+(define-public python-multiprocess
+ (package
+ (name "python-multiprocess")
+ (version "0.70.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "multiprocess" version))
+ (sha256
+ (base32
+ "1ip5caz67b3q0553mr8gm8xwsb8x500jn8ml0gihgyfy52m2ypcq"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-dill" ,python-dill)))
+ (home-page "https://pypi.org/project/multiprocess")
+ (synopsis "Multiprocessing and multithreading in Python")
+ (description
+ "This package is a fork of the multiprocessing Python package, a package
+which supports the spawning of processes using the API of the standard
+library's @code{threading} module.")
+ (license license:bsd-3)))