summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-03-13 00:11:12 -0400
committerLeo Famulari <leo@famulari.name>2017-03-13 15:33:54 -0400
commit7cb68a3cb3082cb6ae5435c28ae7f9278e4d1a0f (patch)
treeae6240a4f3a278cad7e894b96fa6b84864b2720a /gnu/packages/python.scm
parentbe81133a13932bc83b0697d73581a47674ef6987 (diff)
downloadguix-patches-7cb68a3cb3082cb6ae5435c28ae7f9278e4d1a0f.tar
guix-patches-7cb68a3cb3082cb6ae5435c28ae7f9278e4d1a0f.tar.gz
gnu: Remove python-3.4.
* gnu/packages/python.scm (python-3.4): Remove variable. * gnu/packages/patches/python-3.4-fix-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm17
1 files changed, 0 insertions, 17 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2a7257b21d..60f0594453 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -344,23 +344,6 @@ data types.")
(version-major+minor version)
"/site-packages"))))))))
-(define-public python-3.4
- (package (inherit python-3.5)
- (version "3.4.5")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://www.python.org/ftp/python/"
- version "/Python-" version ".tar.xz"))
- (patches (search-patches
- "python-fix-tests.patch"
- "python-3.4-fix-tests.patch"
- "python-3-deterministic-build-info.patch"
- "python-3-search-paths.patch"))
- (patch-flags '("-p0"))
- (sha256
- (base32
- "12l9klp778wklxmckhghniy5hklss8r26995pyd00qbllk4b2r7f"))))))
-
;; Current 3.x version.
(define-public python-3 python-3.5)