summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2017-11-28 14:51:45 -0500
committerLeo Famulari <leo@famulari.name>2017-11-28 14:51:45 -0500
commit76040f71f116b4f788d6748a523eaa4ea18d1cf0 (patch)
tree7a4507bb7be4126eb4b40df9787ae4fb1e211454 /gnu/packages/python.scm
parenta39211febd46fdc7c55340693abe1e7dd1110dbb (diff)
downloadguix-patches-76040f71f116b4f788d6748a523eaa4ea18d1cf0.tar
guix-patches-76040f71f116b4f788d6748a523eaa4ea18d1cf0.tar.gz
gnu: Add python2-booleanoperations.
* gnu/packages/python.scm (python2-booleanoperations): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9bff57a562..9e89e0d111 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -11911,3 +11911,32 @@ belong to tagged versions.")
(define-public python2-pyclipper
(package-with-python2 python-pyclipper))
+
+(define-public python2-booleanoperations
+ (package
+ (name "python2-booleanoperations")
+ (version "0.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "booleanOperations" version ".zip"))
+ (sha256
+ (base32
+ "1hw42fazdpvsn77glx96hwsj9l17mvx37sc5707s08y5w6fx16mn"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2))
+ (native-inputs
+ `(("unzip" ,unzip)
+ ("python2-pytest-3.0" ,python2-pytest-3.0)
+ ("python2-pytest-runner" ,python2-pytest-runner)))
+ (propagated-inputs
+ `(("python-fonttools" ,python2-fonttools)
+ ("python-pyclipper" ,python2-pyclipper)
+ ("python-ufolib" ,python2-ufolib)))
+ (home-page "https://github.com/typemytype/booleanOperations")
+ (synopsis "Boolean operations on paths")
+ (description
+ "BooleanOperations provides a Python library that enables
+boolean operations on paths.")
+ (license license:expat)))