summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2017-12-24 16:23:50 -0500
committerKei Kebreau <kkebreau@posteo.net>2017-12-27 11:51:15 -0500
commit15b60fc3138e9d601aff3e3317373ed465e6ea93 (patch)
treee2475e5eec1a32c6f17ca4d88980df6b25acbb5a /gnu/packages/python.scm
parentaa498fc00320d38a37668e2b024bdc7337434c07 (diff)
downloadguix-patches-15b60fc3138e9d601aff3e3317373ed465e6ea93.tar
guix-patches-15b60fc3138e9d601aff3e3317373ed465e6ea93.tar.gz
gnu: python-pillow: Fix test failures on i686-linux and armhf-linux.
* gnu/packages/patches/python-pillow-fix-failing-tests.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/python.scm (python-pillow)[source]: Use it.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7ff1e78bbe..ce3aa299bc 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3739,7 +3739,9 @@ the OleFileIO module from PIL, the Python Image Library.")
(uri (pypi-uri "Pillow" version))
(sha256
(base32
- "09xmn7rl6840sli2iz1k3fgxfgmri2nqz6vkinmb9mgg8ifp2z59"))))
+ "09xmn7rl6840sli2iz1k3fgxfgmri2nqz6vkinmb9mgg8ifp2z59"))
+ (patch-flags '("-p1" "--binary"))
+ (patches (search-patches "python-pillow-fix-failing-tests.patch"))))
(build-system python-build-system)
(native-inputs
`(("python-nose" ,python-nose)))