summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-27 16:49:05 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-27 16:49:05 +0200
commit397334d9777592176608184adc5e59d2494719ea (patch)
treeeeacb707ceb55f4e2991306746ca8876658f09cc /gnu/packages/python.scm
parentb49e1e81db2234ea408b903d1cdf9c93434e237c (diff)
downloadguix-patches-397334d9777592176608184adc5e59d2494719ea.tar
guix-patches-397334d9777592176608184adc5e59d2494719ea.tar.gz
gnu: python-pillow: Update to 5.2.0.
* gnu/packages/patches/python-pillow-fix-failing-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/python.scm (python-pillow): Update to 5.2.0. [source](patches, patch-flags): Remove. [native-inputs]: Replace PYTHON-NOSE with PYTHON-PYTEST. [arguments]: Adjust custom check phase accordingly.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a761fcfc22..6730dc3f1b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3930,19 +3930,17 @@ the OleFileIO module from PIL, the Python Image Library.")
(define-public python-pillow
(package
(name "python-pillow")
- (version "4.3.0")
+ (version "5.2.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Pillow" version))
(sha256
(base32
- "09xmn7rl6840sli2iz1k3fgxfgmri2nqz6vkinmb9mgg8ifp2z59"))
- (patch-flags '("-p1" "--binary"))
- (patches (search-patches "python-pillow-fix-failing-tests.patch"))))
+ "1ary9mj2ddllq3lkxgn6aac7qxqiwbcg2pacrl94py58ql9x9czq"))))
(build-system python-build-system)
(native-inputs
- `(("python-nose" ,python-nose)))
+ `(("python-pytest" ,python-pytest)))
(inputs
`(("freetype" ,freetype)
("lcms" ,lcms)
@@ -3963,9 +3961,8 @@ the OleFileIO module from PIL, the Python Image Library.")
;; Make installed package available for running the
;; tests
(add-installed-pythonpath inputs outputs)
- (and (zero? (system* "python" "selftest.py"
- "--installed"))
- (zero? (system* "python" "test-installed.py"))))))
+ (invoke "python" "selftest.py" "--installed")
+ (invoke "python" "-m" "pytest" "-vv"))))
(delete 'check))))
(home-page "https://pypi.python.org/pypi/Pillow")
(synopsis "Fork of the Python Imaging Library")