summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-03-08 23:28:33 +0530
committerMarius Bakke <mbakke@fastmail.com>2017-03-09 17:09:17 +0100
commitc220f0b4740fb95e1b8e27d1a6fca00b68dd6df0 (patch)
treef2b6fa38a631dcd85a8af209acb9402f192282b1 /gnu/packages/python.scm
parent77e9941160e40bdf6f1260f360121bccb58be313 (diff)
downloadguix-patches-c220f0b4740fb95e1b8e27d1a6fca00b68dd6df0.tar
guix-patches-c220f0b4740fb95e1b8e27d1a6fca00b68dd6df0.tar.gz
gnu: Add python2-tracing.
* gnu/packages/python.scm (python2-tracing): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7783cf9ab1..2e68db72d7 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -13541,3 +13541,29 @@ command line programs. Output is automatically adapted to the width
of the terminal: truncated if it does not fit, and resized if the
terminal size changes.")
(license license:gpl3+)))
+
+(define-public python2-tracing
+ (package
+ (name "python2-tracing")
+ (version "0.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://git.liw.fi/cgi-bin/cgit/cgit.cgi/python-tracing/snapshot/tracing-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "06cw4zg42fsvqy372vi2whj26w56vzg5axhzwdjc2bgwf03garbw"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2))
+ (home-page "https://liw.fi/tracing/")
+ (synopsis "Python debug logging helper")
+ (description "@code{python2-tracing} is a python library for
+logging debug messages. It provides a way to turn debugging messages
+on and off, based on the filename they occur in. It is much faster
+than using @code{logging.Filter} to accomplish the same thing, which
+matters when code is run in production mode. The actual logging still
+happens using the @code{logging} library.")
+ (license license:gpl3+)))