summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-02-24 18:24:06 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-02-24 18:55:29 +0100
commit42945fb58c4652943a036c99f9bcc59fab61909b (patch)
treefd767e5b8725ea24983bb048962206fa22de2cbe /gnu/packages/python.scm
parentdc027d401471955a3edd17cdd810357c6c01ca41 (diff)
downloadguix-patches-42945fb58c4652943a036c99f9bcc59fab61909b.tar
guix-patches-42945fb58c4652943a036c99f9bcc59fab61909b.tar.gz
gnu: python-fake-factory: Fix build on 32bit.
* gnu/packages/patches/python-fake-factory-fix-build-32bit.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/python.scm (python-fake-factory, python2-fake-factory)[source]: Use it.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 8353ca178f..e26e442e58 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -11228,7 +11228,10 @@ parsing UK postcodes.")
(uri (pypi-uri "fake-factory" version))
(sha256
(base32
- "0vs0dkmg0dlaxf8w6q2i3k0i03gmp56ablldv7ci9x3nbadkn71g"))))
+ "0vs0dkmg0dlaxf8w6q2i3k0i03gmp56ablldv7ci9x3nbadkn71g"))
+ (patches
+ (search-patches
+ "python-fake-factory-fix-build-32bit.patch"))))
(build-system python-build-system)
(arguments
'(#:phases