summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-03-11 20:20:50 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-03-12 18:40:56 +0100
commite4d34cd0f0ced54210ed2df2b251430a9c98c6f4 (patch)
tree3d391e7ac3857277b133ee590138c276f9390bb0 /gnu/packages/python.scm
parent343cee8af31e4dd917b88bec768a95dc449cadce (diff)
downloadguix-patches-e4d34cd0f0ced54210ed2df2b251430a9c98c6f4.tar
guix-patches-e4d34cd0f0ced54210ed2df2b251430a9c98c6f4.tar.gz
gnu: python@3.5: Fix getentropy() calls on kernels < 3.17.
* gnu/packages/patches/python-3.5-getentropy-on-old-kernels.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/python.scm (python-3.5, python-minimal, python-minimal-wrapper, python-wrapper)[source]: Use it.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 6e41108df6..2a7257b21d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -325,6 +325,7 @@ data types.")
(patches (search-patches
"python-fix-tests.patch"
"python-3.5-fix-tests.patch"
+ "python-3.5-getentropy-on-old-kernels.patch"
"python-3-deterministic-build-info.patch"
"python-3-search-paths.patch"))
(patch-flags '("-p0"))