summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-01-05 17:45:17 -0500
committerLeo Famulari <leo@famulari.name>2018-01-05 17:48:44 -0500
commit20c295f9f3d8dfaac9da50502354541ea9cdb01a (patch)
treeb787ffb8368244edcc8010daafed3206b504939b /gnu/packages/python.scm
parent4d6ed794dd10fb3d969e62c49f372d08ba5974b3 (diff)
downloadguix-patches-20c295f9f3d8dfaac9da50502354541ea9cdb01a.tar
guix-patches-20c295f9f3d8dfaac9da50502354541ea9cdb01a.tar.gz
gnu: python2-subprocess32: Skip the tests.
* gnu/packages/python.scm (python2-subprocess32)[arguments]: Skip the tests.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm14
1 files changed, 5 insertions, 9 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4c69f5ad65..5d87c7486e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7166,6 +7166,10 @@ Python at your fingertips, in Lisp form.")
(build-system python-build-system)
(arguments
`(#:python ,python-2
+ ;; The test suite fails with Python > 2.7.13:
+ ;; import test.support
+ ;; ImportError: No module named support
+ #:tests? #f
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-/bin/sh
@@ -7173,15 +7177,7 @@ Python at your fingertips, in Lisp form.")
(substitute* '("subprocess32.py"
"test_subprocess32.py")
(("/bin/sh") (which "sh")))
- #t))
- (delete 'check)
- (add-after 'install 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- ;; For some reason this package fails to import
- ;; _posixsubprocess.so when PYTHONPATH is set to the build
- ;; directory. Running tests after install is easier.
- (add-installed-pythonpath inputs outputs)
- (zero? (system* "python" "test_subprocess32.py")))))))
+ #t)))))
(home-page "https://github.com/google/python-subprocess32")
(synopsis "Backport of the subprocess module from Python 3.2")
(description