summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-03-01 13:35:19 -0500
committerLeo Famulari <leo@famulari.name>2021-03-02 16:55:06 -0500
commit3905580180d8f8ed1eec07baa307b4bff0d726d6 (patch)
tree97bd6f4e3d7e482c1df9ceb307a3dab8bef6598f /gnu/packages/python.scm
parentc48c69194fee468d2ac16ccc25f012312083bf89 (diff)
downloadguix-patches-3905580180d8f8ed1eec07baa307b4bff0d726d6.tar
guix-patches-3905580180d8f8ed1eec07baa307b4bff0d726d6.tar.gz
gnu: Python 2: Fix CVE-2021-3177.
* gnu/packages/patches/python-2.7-CVE-2021-3177.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/python.scm (python-2.7)[replacement]: New field. (python-2.7/fixed): New variable.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9d97050c66..e05c91b3d0 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -107,6 +107,7 @@
(define-public python-2.7
(package
(name "python2")
+ (replacement python-2.7/fixed)
(version "2.7.17")
(source
(origin
@@ -350,6 +351,14 @@ data types.")
(properties '((cpe-name . "python")))
(license license:psfl)))
+(define python-2.7/fixed
+ (package
+ (inherit python-2.7)
+ (source (origin
+ (inherit (package-source python-2.7))
+ (patches (append (search-patches "python-2.7-CVE-2021-3177.patch")
+ (origin-patches (package-source python-2.7))))))))
+
;; Current 2.x version.
(define-public python-2 python-2.7)