summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-04-30 23:49:28 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-05 22:38:16 +0200
commiteb866b3699e5353afa4791e55fd34bc1cb402b0d (patch)
tree5e30ee1317ae0933d5d1ea2b1d7cd54e7d1f7e64 /gnu/packages/python-xyz.scm
parenta3ff747a48d01588d6bcc71787d7c7bd431c9cf3 (diff)
downloadguix-patches-eb866b3699e5353afa4791e55fd34bc1cb402b0d.tar
guix-patches-eb866b3699e5353afa4791e55fd34bc1cb402b0d.tar.gz
gnu: Add python-array-api-compat.
* gnu/packages/python-xyz.scm (python-array-api-compat): New variable. Change-Id: Ibfd701630b41f860c7ad4df57fd3624d9c5b7752
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9d01ac4711..8f018cb512 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1037,6 +1037,27 @@ transformation of the plane.")
from a docstring rather than the other way around.")
(license license:mpl2.0)))
+(define-public python-array-api-compat
+ (package
+ (name "python-array-api-compat")
+ (version "1.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "array_api_compat" version))
+ (sha256
+ (base32 "1bvn92v52h8p2zpinwv5bl1314kdjw3msalj91nczfdbrmay78bl"))))
+ (build-system pyproject-build-system)
+ ;; Tests would require all supported array libraries, including pytorch
+ (arguments (list #:tests? #false))
+ (propagated-inputs (list python-numpy))
+ (home-page "https://data-apis.org/array-api-compat/")
+ (synopsis "Array API compatibility wrapper for NumPy et al")
+ (description
+ "This package provides a wrapper around @code{NumPy} and other array
+libraries to make them compatible with the Array API standard")
+ (license license:expat)))
+
(define-public python-cachetools
(package
(name "python-cachetools")