summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorDavid Elsing <david.elsing@posteo.net>2024-03-23 22:04:42 +0000
committerLudovic Courtès <ludo@gnu.org>2024-06-18 11:32:55 +0200
commit7e3a2272e11673127cd5a95d0585fea3e2f084fb (patch)
treecfa43a126b447e9c074a43ff67f51a8c395bf956 /gnu/packages/python-xyz.scm
parentb452dd635f616baf85bb4568fe71f6c973ad9a36 (diff)
downloadguix-patches-7e3a2272e11673127cd5a95d0585fea3e2f084fb.tar
guix-patches-7e3a2272e11673127cd5a95d0585fea3e2f084fb.tar.gz
gnu: Add python-optree.
* gnu/packages/python-xyz.scm (python-optree): New variable. * gnu/packages/patches/python-optree-fix-32-bit.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Change-Id: I37e38ef9da5e7459c8faf2c3494e2e0c0aedbfff
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8f2e6fc222..9ad89b8c32 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -152,6 +152,7 @@
;;; Copyright © 2024 Adriel Dumas--Jondeau <leirda@disroot.org>
;;; Copyright © 2024 Navid Afkhami <navid.afkhami@mdc-berlin.de>
;;; Copyright © 2024 TakeV <takev@disroot.org>
+;;; Copyright © 2024 David Elsing <david.elsing@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -12213,6 +12214,35 @@ without using the configuration machinery.")
"This package provides a Python implementation of a tree structure.")
(license license:asl2.0)))
+(define-public python-optree
+ (package
+ (name "python-optree")
+ (version "0.10.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/metaopt/optree")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1q3wljk7cyl5rsam02sfsj8zjrqx4c3x9vic8j6xx13p8czpsisg"))
+ (patches (search-patches "python-optree-fix-32-bit.patch"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-typing-extensions))
+ (native-inputs
+ (list python-pytest
+ python-pytest-cov
+ python-pytest-xdist
+ cmake
+ pybind11))
+ (home-page "https://github.com/metaopt/optree")
+ (synopsis "Optimized PyTree Utilities")
+ (description "This package contains operations on PyTrees (a tree made of
+container data structures in Python).")
+ (license license:asl2.0)))
+
(define-public python-jupyter-core
(package
(name "python-jupyter-core")