summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-02 21:37:52 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-05 22:38:17 +0200
commit6244177e793b0e48090973875b23b65967f28504 (patch)
tree0cfb6db4a6ddde17a42d04b8b5d66e55361671e1 /gnu/packages/python-xyz.scm
parentee9720b2f012d32252f36b698a687a54f60549c1 (diff)
downloadguix-patches-6244177e793b0e48090973875b23b65967f28504.tar
guix-patches-6244177e793b0e48090973875b23b65967f28504.tar.gz
gnu: snakemake-6: Make compatible with tabulate 0.9.0.
* gnu/packages/python-xyz.scm (snakemake-6)[arguments]: Add phase 'tabulate-compatibility. Change-Id: I0471726e2000af76871e2542ed347cd1727bf0c9
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c70e44270f..10d920b4b6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13274,6 +13274,11 @@ Python style, together with a fast and comfortable execution environment.")
(substitute* "snakemake/executors/__init__.py"
(("\\{sys.executable\\} -m snakemake")
(string-append #$output "/bin/snakemake")))))
+ (add-after 'unpack 'tabulate-compatibility
+ (lambda _
+ (substitute* "snakemake/dag.py"
+ (("\"job\": rule,")
+ "\"job\": rule.name,"))))
(add-after 'unpack 'patch-version
(lambda _
(substitute* "setup.py"