summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-01 02:47:54 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:47 -0400
commit2d9550cf6a1e84a334aed1af04a1832d530b2f06 (patch)
treec0c8d5c85e5ed370c922d670b84a02a68fd4a8e4 /gnu/packages/python-xyz.scm
parent191207aae237bb7a797dc29a8935c79f71dd8b71 (diff)
downloadguix-patches-2d9550cf6a1e84a334aed1af04a1832d530b2f06.tar
guix-patches-2d9550cf6a1e84a334aed1af04a1832d530b2f06.tar.gz
gnu: Remove python2-decorator.
* gnu/packages/python-xyz.scm (python2-decorator): Delete variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 1 insertions, 14 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b3af73a99e..8197201aed 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7661,21 +7661,8 @@ PNG, PostScript, PDF, and SVG file output.")
for the average programmer, and to popularize decorators usage giving examples
of useful decorators, such as memoize, tracing, redirecting_stdout, locked,
etc. The core of this module is a decorator factory.")
- (license license:expat)
- (properties `((python2-variant . ,(delay python2-decorator))))))
+ (license license:expat)))
-;; Version 5 does not support Python 2
-(define-public python2-decorator
- (package
- (inherit (package-with-python2
- (strip-python2-variant python-decorator)))
- (version "4.3.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "decorator" version))
- (sha256
- (base32 "0308djallnh00v112y5b7nadl657ysmkp6vc8xn51d6yzc9zm7n3"))))))
(define-public python-drmaa
(package